This incident has been resolved and dashboard load times returned to normal by 10:55 UTC. As a note, our beta agent simulations feature was also impacted from approximately 06:07 - 07:52 UTC.
Posted Sep 02, 2026 - 04:57 PDT
Monitoring
A fix has been deployed as of 10:55 UTC, and the dashboard is now loading successfully. We are continuing to monitor before marking this resolved.
Posted Sep 02, 2026 - 03:55 PDT
Identified
We have identified the cause: a problematic node in US-East and are deploying a fix. Impact continues to be limited to the dashboard.
Posted Sep 02, 2026 - 02:01 PDT
Investigating
We are currently investigating reports of our dashboard failing to load across multiple regions, beginning at 07:00 UTC. Other services remain unaffected and the impact is limited to the dashboard.
Posted Sep 02, 2026 - 01:15 PDT
This incident affected: Cloud Dashboard (cloud.livekit.io).