Elevated latency in Hyderabad region

Incident Report for LiveKit

Resolved

We identified a connectivity problem in the Hyderabad cluster. As mitigation, we've drained the cluster to route traffic away from it. Mumbai traffic is unaffected and serving normally. We'll undrain Hyderabad once we're confident it's functioning normally.
Posted Jun 05, 2026 - 04:08 PDT

Update

As of 09:21 UTC, we've applied a mitigation by routing traffic away from the Hyderabad region. Latency rates are returning to normal levels. We're continuing to monitor the issue.
Posted Jun 05, 2026 - 03:05 PDT

Investigating

We're investigating elevated latency affecting Ingress and SIP services in our Hyderabad region.
Posted Jun 05, 2026 - 02:06 PDT
This incident affected: Regional SIP (India - SIP) and Regional Ingress (India - Ingress).