Egress compatibility failures
Incident Report for LiveKit
Postmortem

Oct 21st, 6:17 UTC
A user notified us that Egress was not working for them, and we began looking into the issue.

Oct 21st, 6:40 UTC
We reverted the change which caused the outage.

This breakage was caused by a compatibility issue with SDKs greater than 6 months old. We have since added tests to our end to end test suite using older SDK versions to ensure compatibility in the future.

Posted Oct 23, 2023 - 16:55 PDT

Resolved
Egress failing to start when using SDK versions more than 6 months old.
Posted Oct 20, 2023 - 22:00 PDT