Elevated rate of egress ending early in India region

Incident Report for LiveKit

Postmortem

Summary

Between June 5 and June 16, 2026, an intermittent loss of connectivity between internal systems caused room state to be altered incorrectly in a single region in India. As a result, a small number of active sessions in that region ended earlier than expected, and affected egress recordings could stop mid-session. While the intermittent issue was undetected for some time, the impacted number of egresses was low and limited to the one affected region in India - other regions were unaffected.

Timeline (UTC)

  • 2026-06-05 05:00 - Intermittent loss of connectivity between internal systems begins causing room state to be incorrectly altered in one India region, leading to some egresses being terminated prematurely.
  • 2026-06-16 06:45 - Mitigation was deployed and monitoring began. Eligible connections were moved to a different region and added redundancy was deployed to the affected internal tooling.
  • 2026-06-16 20:42 - No further instances were observed since the mitigation was applied. Incident was marked resolved.

Resolution

We mitigated the outage by moving eligible connections to a different region and by adding redundancy to the affected internal tooling so it could better tolerate intermittent connectivity loss. As a longer-term fix, we hardened the communication channels between the involved systems. We have not observed any further occurrences since the mitigation was applied, and we are continuing to evaluate additional improvements to our tolerance for this class of failure.

Posted Jun 23, 2026 - 10:48 PDT

Resolved

We have not seen further instances of this issue since the mitigation was applied. We will follow up with a postmortem as soon as possible.
Posted Jun 16, 2026 - 13:42 PDT

Monitoring

We identified an issue in the India region where a small number of active sessions may have ended earlier than expected. Affected sessions could experience egress recordings stopping mid-session.

We've deployed a mitigation and are monitoring to confirm resolution. Other regions are unaffected.
Posted Jun 16, 2026 - 02:49 PDT
This incident affected: Regional Egress (India - Egress).